您的位置:首页 > 其它

DP--UVA - 437 The Tower of Babylon

2015-11-04 13:30 429 查看
Description





Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:
The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions

.
A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower,
one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized
bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is
30. Each of the next n lines contains three integers representing the values

,

and

.
Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Casecase: maximum
height =height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0


Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


分析:在任何时候只有顶面的尺寸会影响到后续的决策,因此可以用二元组(a, b),但由于边长的取值范围太大,这里可以用(idx, k)这个二元组来”间接“表达这个状态,其中idx为顶面立方体的序号,k是高的序号。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 33;
int G[maxn][3], d[maxn][3];
int n;

bool valid(int id1, int k1, int id2, int k2)
{
int a1 = G[id1][(k1+1)%3], b1 = G[id1][(k1+2)%3];
int a2 = G[id2][(k2+1)%3], b2 = G[id2][(k2+2)%3];
if(a1 < b1) swap(a1, b1); if(a2 < b2) swap(a2, b2);
if(a1 <= a2 || b1 <= b2) return false;
return true;
}

int dp(int id, int k)
{
int& ans = d[id][k];
if(ans > 0) return ans;
for(int i=0; i<n; i++) {
for(int j=0; j<3; j++) {
if(valid(id, k, i, j)) ans = max(ans, dp(i, j));
}
}
return ans += G[id][k];
}

int main()
{
int kase = 0;
while(scanf("%d", &n), n) {
for(int i=0; i<n; i++) {
scanf("%d%d%d", &G[i][0], &G[i][1], &G[i][2]);
sort(G[i], G[i]+3);
}
memset(d, 0, sizeof(d));
int ans = 0;
for(int i=0; i<n; i++)
for(int j=0; j<3; j++)
ans = max(ans, dp(i, j));
printf("Case %d: maximum height = %d\n", ++kase, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: