您的位置:首页 > 其它

Codevs_P3186 队列练习2

2015-11-03 20:08 267 查看
题目描述 Description

(此题与队列练习1相比改了2处:1加强了数据 2不保证队空时不会出队)

给定一个队列(初始为空),只有两种操作入队和出队,现给出这些操作请

输出最终的队头元素。 操作解释:1表示入队,2表示出队

输入描述 Input Description

N(操作个数)

N个操作(如果是入队则后面还会有一个入队元素)

具体见样例(输入保证队空时不会出队)

输出描述 Output Description

最终队头元素,若最终队空,或队空时有出队操作,输出”impossible!”(不含引号)

样例输入 Sample Input

3

1 2

2

2

样例输出 Sample Output

impossible!

数据范围及提示 Data Size & Hint

对于100%的数据 N≤100000 元素均为正整数且小于等于10^8

#include<cstdio>
#include<queue>
using namespace std;
queue<int> a;
int n,x,y;
int main(){
scanf("%d",&n);
while(n--){
scanf("%d",&x);
if(x==1){
scanf("%d",&y);
a.push(y);
}
else if(!a.empty()) a.pop();
else {printf("impossible!\n");return 0;}
}
if(a.empty()) printf("impossible!\n");
else printf("%d",a.front());
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  STL 队列 Codevs