您的位置:首页 > 其它

hdoj 2955 Robberies【01背包】【dp】

2015-11-03 17:14 465 查看

Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17391 Accepted Submission(s): 6435



[align=left]Problem Description[/align]
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only
for a short while, before retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

[align=left]Input[/align]
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then
follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

[align=left]Output[/align]
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

[align=left]Sample Input[/align]

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05


[align=left]Sample Output[/align]

2
4
6


Mj是背包体积, Pj 是背包价值~

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f;
double dp[20000];
struct node{
int v;//背包  体积
double val;// 背包价值
};
node p[1200];
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
int i,j,k,n;
double a;
scanf("%lf%d", &a, &n);//被抓概率,n个银行
a = 1-a;//成功逃脱概率
for(i = 1, k = 0; i <= n; i++)
{
scanf("%d%lf", &p[i].v, &p[i].val);
k += p[i].v;//背包总体积
p[i].val = 1-p[i].val;//把被抓几率都转换成逃脱概率
}
for(i = 1; i <= k; i++)
dp[i] = -1;
dp[0] = 1;//一分钱不抢 不被抓 逃脱概率100%
for(i = 0; i <= n; i++)
{
for(j = k; j >= p[i].v; j--)
{
dp[j] = max(dp[j], dp[j-p[i].v]*p[i].val);//抢成功时 概率相乘 并求最大值
}
}
for(  ; k >= 0; k--)
{
if(dp[k] >= a)
break;//直到逃脱概率到最低限度时退出循环 成功抢到最多的钱且不被抓
}
printf("%d\n", k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: