您的位置:首页 > 其它

poj 1250&Toj 1932 Tanning Salon【巧妙模拟】

2015-11-03 16:52 197 查看
Tanning Salon

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8063 Accepted: 4319
Description

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells
the company how many customers left without tanning. 

Input

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed
by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair.
Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon. 

Output

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below. 

Sample Input
2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output
All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.


有n个位置,很多人依次去被服务,第一次出现代表俩,第二次出现代表走,请问经过一系列操作,一共多少顾客没得到服务。

这道题要求比较简单,不过题目不太严谨,题目中,如果有空位,排队等待的人是不会被服务的,然后自己多想了,wa.......

事实上,应该可以考虑复杂些的.... 

个人比较巧妙的做法是用不同的数字来代替每个人不同的状态,这样容易分情况处理!

#include<stdio.h>
#include<string.h>
int main()
{
int n;
//freopen("shuju.txt","r",stdin);
while(scanf("%d",&n),n)
{
int x[26],ch,cnt=0,bed=0;
memset(x,-1,sizeof(x));
//-1是还没来过,1是进行了服务,0是在等待中
getchar();
while((ch=getchar())!='\n')
{
int tp=ch-'A';
if(x[tp]==-1)//没来过
{
x[tp]=0;//等一下
if(bed<n)//还有床位,就
{
x[tp]=1;
++bed;
}
}
else if(x[tp]==0)//已经在等待中..
{
x[tp]=-1;
++cnt;
}
else//服务中
{
x[tp]=-1;
--bed;
}
}
if(cnt)
{
printf("%d customer(s) walked away.\n",cnt);
continue;
}
printf("All customers tanned successfully.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: