您的位置:首页 > 产品设计 > UI/UE

HDU 4027 Can you answer these queries?

2015-11-02 21:00 369 查看
[align=left]Problem Description[/align]
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our
secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of
the weapon, so he asks you for help.

You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

[align=left]Input[/align]
The input contains several test cases, terminated by EOF.

  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)

  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.

  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)

  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query
of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

 

[align=left]Output[/align]
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

[align=left]Sample Input[/align]

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

 

[align=left]Sample Output[/align]

Case #1:
19
7
6

 

[align=left]Source[/align]
The 36th ACM/ICPC Asia Regional Shanghai Site —— Online
Contest
 

[align=left]Recommend[/align]
lcy   |   We have carefully selected several similar problems for you:  3308 2871 2795 1542 3397 
 

线段树区间操作,将某区间的所有数变成它的开方。
因为一个数最多开方8次还是7次就变成1,此时值等于r-l+1.不管就行了。
#include <cstdio>
#include <cstring>
#include <cmath>
#include <set>
#include <iostream>
#include <algorithm>
using namespace std ;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
typedef long long ll ;
ll sum[100000*4];
void pushup(int rt)
{
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
if(l==r)
{
scanf("%lld",&sum[rt]);
return;
}
int m=(l+r)>>1;
build(lson);
build(rson);
pushup(rt);
}
void update(int L,int R,int l,int r,int rt)
{
if(sum[rt]==r-l+1)
return;
if(l==r)
{
sum[rt]=sqrt(1.0*sum[rt]);
return;
}
int m=(l+r)>>1;
if(L<=m)
update(L,R,lson);
if(m<R)
update(L,R,rson);
pushup(rt);
}
ll query(int L,int R,int l,int r,int rt)
{
if(L<=l &&r<=R)
return sum[rt];
ll ans=0;
int m=(l+r)>>1;
if(L<=m)
ans+=query(L,R,lson);
if(m<R)
ans+=query(L,R,rson);
return ans;
}
int main()
{
int n;
int icase=1;
while(~scanf("%d",&n))
{
build(1,n,1);
int m;
printf("Case #%d:\n",icase++);
scanf("%d",&m);
int c,x,y;
while(m--)
{
scanf("%d%d%d",&c,&x,&y);
if(x>y)
swap(x,y);
if(c==1)
{
printf("%lld\n",query(x,y,1,n,1));
}
else
{
update(x,y,1,n,1);
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM算法