您的位置:首页 > 其它

HDOJ 题目 1300 Pearls(DP水)

2015-11-01 20:37 399 查看

Pearls

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1963 Accepted Submission(s): 929



[align=left]Problem Description[/align]
In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets
and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family. In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the
price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.

Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain
quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.

Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is
actually needed. No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the prices remain the same.

For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10 + (100+10)*20 = 2350 Euro.

Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.

The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested, or in a higher quality class, but not in a lower one.

[align=left]Input[/align]
The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1 <= c <= 100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers
is the number of pearls ai needed in a class (1 <= ai <= 1000). The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.

[align=left]Output[/align]
For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

[align=left]Sample Input[/align]

2
2
100 1
100 2
3
1 10
1 11
100 12


[align=left]Sample Output[/align]

330
1344


[align=left]Source[/align]
Northwestern Europe 2002

[align=left]Recommend[/align]
Eddy | We have carefully selected several similar problems for you: 1227 1080 1422 1502 3008
题目大意:给出每个等级所需要的树和每个等级的价格,每买一个等级的东西是买他的数量再加10乘价格的消耗,低等级的可以高等级的满足,问最小消耗,(从1到n等级上升,价格上升)
ac代码

153419392015-11-01 20:31:54Accepted13000MS1704K889 BC++XY_
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define INF 0x3f3f3f3f3f3f3f
#define LL long long
using namespace std;
struct s
{
LL a,b;
}p[110];
LL sum[110],dp[110];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
int i,j;
sum[0]=0;
for(i=1;i<=n;i++)
{
scanf("%lld %lld",&p[i].a,&p[i].b);
sum[i]=sum[i-1]+p[i].a;
}
memset(dp,INF,sizeof(dp));
dp[0]=0;
dp[1]=(p[1].a+10)*p[1].b;
for(i=2;i<=n;i++)
{
for(j=0;j<i;j++)
{
// printf("%d %lld %lld\n",j,dp[j],dp[j]+(sum[i]-sum[j]+10)*p[i].b);
dp[i]=min(dp[i],dp[j]+(sum[i]-sum[j]+10)*p[i].b);
}
}
printf("%lld\n",dp
);
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: