您的位置:首页 > 其它

hdoj4727The Number Off of FFF

2015-10-31 23:33 260 查看
L - The Number Off of FFF
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
4727

Description

X soldiers from the famous " *FFF* army" is standing in a line, from left to right. 

You, as the captain of *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the
soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right. 

Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers
stands continuously in the original line, from left to right. 

We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
 

Input

The rst line has a number T (T <= 10) , indicating the number of test cases. 

For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 105) 

It guaranteed that there is exactly one soldier who has made the mistake.
 

Output

For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
 

Sample Input

2
3
1 2 4
3
1001 1002 1004

 

Sample Output

Case #1: 3
Case #2: 3

给出一个序列后一位都比前一位大一当一位报错是后面的数以该数为准继续加大只有一位报错了求这一位数

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
long long num[100010];
int main()
{
int n,t,k=1,i,j;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(i=0;i<n;++i){
scanf("%lld",&num[i]);
}
int pos=-1;
for(i=1;i<n;++i){
if(num[i]-num[i-1]!=1){
pos=i;
break;
}
}
if(pos==-1)pos=0;
printf("Case #%d: %d\n",k++,pos+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdoj4727The Number O