您的位置:首页 > 其它

文章标题

2015-10-31 13:27 337 查看
大一玩过一年的ACM,偶然在杭电ACM oj看到自己曾经刷的题,现在居然连题目类型都说不出了。。。。

FatMouse’ Trade

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333

31.500

我AC 过的代码,不知道我在写啥。。。。。

#include<stdio.h>
#include<stdlib.h>
#define MAX 10000
struct home
{
int a;
int b;
double c;
}s[MAX];
int cmp(const void *aa,const void *bb)
{
return ((((struct home *)aa)->c)>(((struct home *)bb)->c))?-1:1;
}
int main()
{
int m,n,i;
while(~scanf("%d%d",&m,&n))
{
if(m==-1&&n==-1)
break;
for(i=0;i<n;i++)
{
scanf("%d%d",&s[i].a,&s[i].b);
s[i].c=(double)(s[i].a*1.0/s[i].b);
}
qsort(s,n,sizeof(s[0]),cmp);
//for(i=0;i<n;i++)
//  printf("%d %d %.3lf\n",s[i].a,s[i].b,s[i].c);
double sum=0.0;
for(i=0;i<n;i++)
{
if(m>=s[i].b)
{
m-=s[i].b;
sum+=s[i].a;
}
else //if(m<s[i].b)
{
sum+=m*s[i].c;
break;
}
}
printf("%.3lf\n",sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: