您的位置:首页 > 产品设计 > UI/UE

sicily 1443. Printer Queue

2015-10-30 20:50 357 查看

1443. Printer Queue

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page
of output.

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority,

and 1 being the lowest), and the printer operates as follows.

The first job J in queue is taken from the queue.
If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.

Otherwise, print job J (and do not put it back in the queue).

In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life.

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well
as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute,
and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:

One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.

One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input


3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output


1
2
5


题目分析

按照优先级打印任务队列,求一开始某个位置的任务需要的等待时间

简单的队列模拟,开一个数组存储数据,排序后用来做比对

#include <queue>
#include <iostream>
#include <algorithm>

struct Node {
int priority;
int pos;
};

bool com(int a, int b) {
return a > b;
}

int main()
{
int test;
std::cin >> test;
while (test--) {
int num, target;
std::cin >> num >> target;
Node nodes[num];
int value[num];
std::queue<Node> q;
for (int i = 0; i < num; ++i) {
std::cin >> value[i];
nodes[i].pos = i;
nodes[i].priority = value[i];
q.push(nodes[i]);
}
std::sort(value, value+num, com);

int count = 0;
while (true) {
Node temp = q.front();
q.pop();
if (temp.pos == target && temp.priority == value[count])
break;
if (temp.priority == value[count]) {
count++;
} else {
q.push(temp);
}
}
std::cout << count+1 << std::endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: