您的位置:首页 > 其它

sicily 1323. Switch text

2015-10-30 20:37 393 查看

1323. Switch text

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

The program must switch the text lines in a backward order and split them by the middle, processing the input lines in pairs. If an empty or blank line is found, it is considered as a line but it is not printed out to the output.

Input

The input will be a text file with text lines.

Output

Standard output with the switched and splitted lines.

Sample Input


This lines must be printed backwards and splitted in the middle.
And each line too!
hellow my friend
how are you today
i hope you're fine

be cool, be nice.

Sample Output


hcae dnA!oot enil
wkcab detnirp eb tsum senil sihT.elddim eht ni dettilps dna sdra
y era wohyadot uo
m wollehdneirf y
oy epoh ienif er'u
,looc eb.ecin eb


题目分析

给定两个字符串a和b,

分别在中间截断,前后两个部分分别反序排列,

输出b和a

调用库函数std::reverse(str.begin(), str.end())

注意空字符串和全为空格的行不必处理打印

#include <iostream>
#include <algorithm>

bool isBlank(std::string s) {
for (int i = 0; i < s.length(); ++i)
if (s[i] != ' ')
return false;
return true;
}

int main()
{
std::string s1, s2;
while (getline(std::cin, s1) && getline(std::cin, s2)) {
if (s2.length() > 0 && !isBlank(s2)) {
int mid = (s2.length() + 1) / 2;
std::reverse(s2.begin(), s2.begin()+mid);
std::reverse(s2.begin()+mid, s2.end());
std::cout << s2 << std::endl;
}
if (s1.length() > 0 && !isBlank(s1)) {
int mid = (s1.length() + 1) / 2;
std::reverse(s1.begin(), s1.begin()+mid);
std::reverse(s1.begin()+mid, s1.end());
std::cout << s1 << std::endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: