您的位置:首页 > 其它

LightOJ 1370 - Bi-shoe and Phi-shoe (欧拉函数思想)

2015-10-30 14:00 363 查看
http://lightoj.com/volume_showproblem.php?problem=1370

Bi-shoe and Phi-shoe

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit Status Practice LightOJ 1370

Description

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题目中标红的部分是该题理解的关键,每个学生所得的bamboo的score的值必须大于或等于他的幸运数字, bamboo的score值就是其长度x的欧拉函数值(即小于x且与x互质的数的个数)

每单位长度花费1Xukha,求买这些bamboo的最小花费。

如样例2:6个学生,每个学生的幸运数字分别为10、11 、12、13、14、15

那么给第一个人买的bamboo的score值必须大于或等于10,score值可能为10(x为11)、11、12、等...我们要找x值最小的,显然,这里第一个人买的是长度为11的bamboo

我们知道欧拉函数有一个性质:素数p的欧拉函数值为p-1;

我们要找长度为小的bamboo,只需将幸运数字加1开始找,如果该数字x是素数,那么这个数字x-1就是长度为x的score值,且满足条件,所求的x就是满足条件bamboo的长度

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>

using namespace std;

typedef long long ll;

const int N = 1000010;

int b
= {1, 1, 0};

void dabiao()
{
for(int i = 2 ; i < N ; i++)
{
if(!b[i])
{
for(int j = i + i ; j <= N ; j += i)
b[j] = 1;
}
}

}//素数打表

int main()
{
dabiao();
int t, n, m, x = 0;
scanf("%d", &t);
while(t--)
{
x++;
ll sum = 0;
scanf("%d", &n);
while(n--)
{
scanf("%d", &m);
for(int i = m + 1 ; ; i++)
{
if(b[i] == 0)
{
sum += i;
break;
}
}
}
printf("Case %d: %lld Xukha\n", x, sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: