您的位置:首页 > 其它

POJ 2752 Seek the Name, Seek the Fame

2015-10-29 22:04 393 查看

传送门

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14761   Accepted: 7407

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source

POJ Monthly--2006.01.22,Zeyuan Zhu ---------------------------------------------- 贴代码,回味。。。。。
#include <cstdio>
using namespace std;

const int N(4e5+5);
char s
;
int nt
, ans
;

int main(){
for(int ls, cnt; ~scanf("%s", s);){
for(int i=ls=1, k=0; s[i]; i++, ls++){
while(k&&s[k]!=s[i]) k=nt[k-1];
nt[i]=s[k]==s[i]?++k:k;
}
for(int i=(cnt=0,ls); i; ans[cnt++]=i, i=nt[i-1]);
for(; cnt; printf("%d ", ans[--cnt])); puts("");
}
}

代码有亮点

for(int i=(cnt=0,ls); i; ans[cnt++]=i, i=nt[i-1]);

 

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: