您的位置:首页 > 产品设计 > UI/UE

hdu1711Number Sequence(KMP)

2015-10-28 22:30 465 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16453    Accepted Submission(s): 7245


[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

 

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

[align=left]Sample Output[/align]

6
-1

 题目大意:给你两个数字序列a[]和b[],求b[]序列在a[]序列中最早发生匹配的位置,若不存在,输出-1.
简单的KMP,需要注意的是,由于是都是数字序列,每个数字范围不确定,这是不能当作字符来处理,所以a[]、b[]应定义为整型;
AC代码:
#include<stdio.h>
#include<string.h>
int a[1000100],b[10100];
int p[10010];
int n,m;
void getp()
{
int i=0,j=-1;
p[i]=j;
while(i<m)
{
if(j==-1||b[i]==b[j])
{
i++,j++;
p[i]=j;
}
else
j=p[j];
}
}
int Kmp()
{
int i=0,j=0,k=-1;;
getp();
while(i<n)
{
if(j==-1||a[i]==b[j])
{
i++,j++;
if(j==m)
{
k=i;
break;
}
}
else
j=p[j];
}
return k;
}
int main()
{
int t;
int i,j,x;
scanf("%d",&t);
while(t--)
{
memset(p,0,sizeof(p));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%d%d",&n,&m);
for(i=0;i<n;i++)
{
getchar();
scanf("%d",&a[i]);
}
for(i=0;i<m;i++)
{
getchar();
scanf("%d",&b[i]);
}
x=Kmp();
if(x<0)
printf("-1\n");
else
printf("%d\n",x-m+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: