您的位置:首页 > 其它

HDOJ 1385 Minimum Transport Cost (最短路 Floyd & 路径记录)

2015-10-28 21:13 603 查看

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9076 Accepted Submission(s): 2392

[align=left]Problem Description[/align]
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

[align=left]Input[/align]
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N

a21 a22 ... a2N

...............

aN1 aN2 ... aNN

b1 b2 ... bN

c d

e f

...

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and
g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

[align=left]Output[/align]
From c to d :

Path: c-->c1-->......-->ck-->d

Total cost : ......

......

From e to f :

Path: e-->e1-->..........-->ek-->f

Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

[align=left]Sample Input[/align]

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0


[align=left]Sample Output[/align]

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17


题目链接:HDOJ 1385 Minimum Transport Cost (Floyd & 路径记录)

最短路 Floyd + 路径记录 (模板)

a11 a12 ... a1N

a21 a22 ... a2N

...............

aN1 aN2 ... aNN 两点间花费

b1 b2 .. . bN 进站花费

c d 两点间路径及花费,路径 按字典序(当花费相同,要走编号小的点)

e f

...

g h

注意 输出 格式

已AC代码:

#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f
#define M 500
int map[M][M],path[M][M],cost[M];
int n,st,ed;//map存图,path记录路径,cost进站花费

void Floyd()
{
int i,j,k;
for(k=1;k<=n;++k)
{
for(i=1;i<=n;++i)
{
for(j=1;j<=n;++j)
{
if(map[i][j]>map[i][k]+map[k][j]+cost[k])
{
map[i][j]=map[i][k]+map[k][j]+cost[k];
path[i][j]=path[i][k];//更新 j 前驱点
}
else if(map[i][j]==map[i][k]+map[k][j]+cost[k])
{
if(path[i][j] > path[i][k])//选择较小的点(要求按字典序小的输出)
path[i][j]=path[i][k];
}
}
}
}
}
int main()
{
int a,i,j;
while(scanf("%d",&n),n)
{
for(i=1;i<=n;++i)//输入map
{
for(j=1;j<=n;++j)
{
scanf("%d",&a);
if(a == -1)//不通,无穷大
map[i][j]=INF;
else
map[i][j]=a;

path[i][j]=j;//纪律前驱点
}
}
for(i=1;i<=n;++i)//输入进站花费
scanf("%d",&cost[i]);

Floyd();

while(true)
{
scanf("%d%d",&st,&ed);
if(st==-1 && ed==-1)
break;

printf("From %d to %d :\n",st,ed);
printf("Path: %d",st);

if(st==ed)//起点等于终点 花费为 0
{
printf("\n");
printf("Total cost : 0\n\n");//花费
continue;// 返 回
}
int s=path[st][ed];
while(1)//输出路径
{
printf("-->%d",s);
if(s==ed)
break;
s=path[s][ed];
}
printf("\n");
printf("Total cost : %d\n\n",map[st][ed]);//花费
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: