您的位置:首页 > 其它

骨头陷阱,小狗过迷宫题(Problem ID:1010)

2015-10-28 09:11 363 查看
题址:http://acm.hdu.edu.cn/showproblem.php?pid=1010

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the
maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0

Sample Output

NO

YES

题意:小狗被骨头诱惑,进了迷宫陷阱,迷宫矩阵为N行M列,然后迷宫中有个门,小狗要在指定时间T到达这个门才能逃脱,注意,是一定要在第T秒的时候正好到达门,不能多也不能少,而且,小狗朝各个方向走,不能回头,即走过的砖块不能再走。大致意思就是这样了。

思路:明显是用dfs深搜遍历,(每经过一个砖块,把它写成墙,小狗就没法回头了)...  

            另外还要进行剪枝,剪枝这一步骤非常重要。因为狗的坐标(startx,starty)与门的坐标(endx,endy)奇偶性相反(0-1或1-0)...

       比如5行5列的表示奇偶性  0 1 0 1 0

                                           1 0 1 0 1

                                           0 1 0 1 0

                                           1 0 1 0 1

                                           0 1 0 1 1

    所以奇偶性剪枝:(startx+starty+endx+endy+t)%2==1的直接剪了吧,不用进行搜索了。

    另一个n*m-block<t  表示能走的路都比t要小,那再怎么努力都到不了门了,直接放弃吧。

AC代码:#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

int n,m,t,startx,starty,endx,endy,flag;
char map[10][10];
int direction[4][2]={{1,0},{-1,0},{0,1},{0,-1}};

void dfs(int hang,int lie,int time)
{
if(flag==1) return;
if(hang==endx && lie==endy && time==t)
{ flag=1;return; }
if(time>t)
{ flag=0;return; }
if(map[hang][lie]=='X') return;
map[hang][lie]='X';time++;
for(int i=0;i<4;i++)
{
int x=hang+direction[i][0];
int y=lie+direction[i][1];
if(x<n && y<m && x>=0 && y>=0 && map[x][y]!='X')
{
dfs(x,y,time);
map[x][y]='.';
if(flag) return;
}
}

return ;
}

int main()
{
while(cin>>n>>m>>t)
{
if(n==0 && m==0 && t==0) break;
int block=0;
for(int x=0;x<n;x++)
{
for(int y=0;y<m;y++)
{
cin>>map[x][y];
if(map[x][y]=='S'){ startx=x;starty=y; }
if(map[x][y]=='D'){ endx=x;endy=y; }
if(map[x][y]=='X'){ block++; }
}
}
if(n*m-block<t)
{
printf("NO\n");
continue;
}
if((startx+starty+endx+endy+t)%2==1) //狗的坐标(startx,starty)与门的坐标(endx,endy)奇偶性相反(0-1或1-0)
{
printf("NO\n");
continue;
}
flag=0;
dfs(startx,starty,0);
if(flag==1)
printf("YES\n");
else
printf("NO\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: