您的位置:首页 > 其它

Palindrome(Manacher)

2015-10-25 17:24 211 查看
Palindrome

Time Limit: 15000MSMemory Limit: 65536K
Total Submissions: 6183Accepted: 2270
Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, "Can you propose an efficient algorithm to find the length of the largest palindrome in a string?"

A string is said to be a palindrome if it reads the same both
forwards and backwards, for example "madam" is a palindrome while "acm"
is not.

The students recognized that this is a classical problem but
couldn't come up with a solution better than iterating over all
substrings and checking whether they are palindrome or not, obviously
this algorithm is not efficient at all, after a while Andy raised his
hand and said "Okay, I've a better algorithm" and before he starts to
explain his idea he stopped for a moment and then said "Well, I've an
even better algorithm!".

If you think you know Andy's final solution then prove it! Given a
string of at most 1000000 characters find and print the length of the
largest palindrome inside this string.
Input

Your
program will be tested on at most 30 test cases, each test case is
given as a string of at most 1000000 lowercase characters on a line by
itself. The input is terminated by a line that starts with the string
"END" (quotes for clarity).

Output

For each test case in the input print the test case number and the length of the largest palindrome.

Sample Input

abcbabcbabcba
abacacbaaaab
END

Sample Output

Case 1: 13
Case 2: 6
manacher;
代码:


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#define mem(x,y) memset(x,y,sizeof(x))
using namespace std;
typedef long long LL;
const int INF=0x3f3f3f3f;
const int MAXN=1000010;
char str[MAXN],s[MAXN<<1];
int p[MAXN<<1];
int Manacher(char *s,int len){
p[0]=p[1]=1;
int ans=0,id=1,mx=1;
for(int i=2;i<len;i++){
if(mx>i)p[i]=min(p[2*id-i],mx-i);
else p[i]=1;
while(s[i-p[i]]==s[i+p[i]])p[i]++;
if(p[i]+i>mx)mx=p[i]+i,id=i;
ans=max(ans,p[i]-1);
}
return ans;
}
int main(){
int flot=0;
while(~scanf("%s",str),strcmp(str,"END")){
int len=strlen(str);
s[0]='@';
for(int i=0;i<len;i++){
s[2*i+1]='#';
s[2*i+2]=str[i];
}
s[2*len+1]='#';
printf("Case %d: %d\n",++flot,Manacher(s,2*len+2));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: