您的位置:首页 > 其它

【PAT】1078. Hashing (25)

2015-10-25 17:06 357 查看
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table.
Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct
positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the
number, print "-" instead.
Sample Input:
4 4
10 6 4 15

Sample Output:

0 1 4 -

分析:这道题出得并不好。要知道二次探测法的公式,否则没法做。公式为 

hi=(h(key)+i*i)%m
0≤i≤m-1 知道公式后就简单了。

代码如下:

#include <iostream>
#include <cmath>
#include <vector>

using namespace std;

bool isPrime(int n){
int i;
if(n==1)
return false;
if(n==2 || n==3){
return true;
}
for(i=2; i<=sqrt(n); i++){
if(n%i == 0)
return false;
}
return true;
}

int main(int argc, char** argv) {
int m, n;
int i;
cin>>m>>n;
vector<bool> flag(10000,false);
while(!isPrime(m)){
++m;
}

int val, j;
for(i=0; i<n; i++){
cin>>val;
for(j=0; j<m; j++ ){
if( !flag[(val+j*j)%m] ){
if(i==0)
printf("%d",(val+j*j)%m);
else
printf(" %d",(val+j*j)%m);
flag[(val+j*j)%m] = true;
break;
}
}
if(j==m){
if(i==0)
printf("-");
else
printf(" -");
}
}
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT