您的位置:首页 > 移动开发

HDU 4925 Apple Tree

2015-10-24 15:25 316 查看
[align=left]Problem Description[/align]
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’
production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x +
1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?

[align=left]Input[/align]
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.

For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.

[align=left]Output[/align]
For each test case, you should output the maximum number of apples I can obtain.

[align=left]Sample Input[/align]

2
2 2
3 3


[align=left]Sample Output[/align]

8
32
题意:一个各自要么能种一个苹果数,要么能够施肥,施肥的话,会使得它的上下左右苹果树都加倍,求最多的可能
思路:依次施肥种树计算
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 110;

int map[maxn][maxn];
int n, m;

int cal(int i, int j) {
int ans = 1;
if (map[i][j+1] == 0)
ans <<= 1;
if (map[i+1][j] == 0)
ans <<= 1;
if (map[i-1][j] == 0)
ans <<= 1;
if (map[i][j-1] == 0)
ans <<= 1;
return ans;
}

int main() {
int t;
scanf("%d", &t);
while (t--) {
scanf("%d%d", &n, &m);
memset(map, -1, sizeof(map));
int flag = 0;
for (int i = 1; i <= m; i++) {
map[1][i] = flag;
flag = !flag;
}
for (int i = 2; i <= n; i++)
for (int j = 1; j <= m; j++)
map[i][j] = !map[i-1][j];
int ans = 0;
for (int i = 1; i <= n; i++)
for (int j = 1; j <= m; j++)
if (map[i][j])
ans += cal(i, j);

memset(map, -1, sizeof(map));
flag = 1;
for (int i = 1; i <= m; i++) {
map[1][i] = flag;
flag = !flag;
}
for (int i = 2; i <= n; i++)
for (int j = 1; j <= m; j++)
map[i][j] = !map[i-1][j];
int tmp = 0;
for (int i = 1; i <= n; i++)
for (int j = 1; j <= m; j++)
if (map[i][j])
tmp += cal(i, j);
printf("%d\n", max(ans, tmp));
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: