您的位置:首页 > 其它

[sicily]1500. Prime Gap

2015-10-24 13:10 323 查看


1500. Prime Gap


Constraints

Time Limit: 1 secs, Memory Limit: 32 MB


Description

The sequence of n ? 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime
gap of length n. For example, 24, 25, 26, 27, 28 between 23 and 29 is a prime gap of length 6.
Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.


Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input
is indicated by a line containing a single zero.


Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite
number, or 0 otherwise. No other characters should occur in the output.


Sample Input


10
11
27
2
492170
0


Sample Output


4
0
6
0
114


Problem Source

Tokyo 2007

简单计数题,要我们计算包含k值的相邻两个素数之间的距离。利用筛法求出N以内的素数,然后计算即可。代码如下:

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;

#define N 1299710
bool prime
;

int main()
{
int n;
memset(prime, true, sizeof(prime)); //筛法求N以内的素数。
for(int i=2; i<=sqrt(N); i++)
if(prime[i])
for(int j=i+i; j<N; j=i+j)
prime[j] = false;
while(cin>>n && n>0)
{
int count=0;
if(!prime
)
{
int tmp=n;
while(prime[tmp]==false)
tmp--;
tmp++;
count++;
while(prime[tmp]==false){
tmp++;
count++;
}
}
cout<<count<<endl;
}
// system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  sicily