您的位置:首页 > 其它

九度OJ 1148:Financial Management(财务管理) (平均数)

2015-10-24 12:54 429 查看
与1141题相同。

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:843

解决:502

题目描述:

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out
what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

输入:

Each case will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

输出:

For each case, the output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other
spaces or characters in the output.

样例输入:
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75


样例输出:
$1581.42


来源:2010年北京大学计算机研究生机试真题

代码:

#include <stdio.h>
 
int main(void)
{
    int n, i;
    double cost;
    double sum;
 
    while (scanf("%lf", &cost) != EOF)
    {
        sum = cost;
        for(i=1; i<12; i++)
        {
            scanf("%lf", &cost);
            sum += cost;
        }
        printf("$%.2lf\n", sum/12);
    }
 
    return 0;
}
/**************************************************************
    Problem: 1148
    User: liangrx06
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: