您的位置:首页 > 其它

九度OJ 1144:Freckles(斑点) (最小生成树)

2015-10-24 12:40 489 查看
时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:1538

解决:760

题目描述:

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through.

Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting
the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

输入:

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0


样例输出:
3.41


来源:2009年北京大学计算机研究生机试真题

思路:

求最小生成树,其中的总路径长度即答案。

代码:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>

#define N 100
#define M (N*(N-1)/2)

typedef struct point {
double x;
double y;
} POINT;

typedef struct node {
int x;
int y;
double d;
} ROAD;

int n;
int pre[N+1];
int count[N+1];
int num;

void init()
{
for (int i=1; i<=n; i++)
{
pre[i] = i;
count[i] = 1;
}
num = n;
}

int find(int i)
{
while (i != pre[i])
i = pre[i];
return i;
}

int combine(int i, int j)
{
int a = find(i);
int b = find(j);
if (a != b)
{
if (count[a] > count[b])
{
pre[b] = a;
count[a] += count[b];
count[b] = 0;
}
else
{
pre[a] = b;
count[b] += count[a];
count[a] = 0;
}
num --;
return 1;
}
else
return 0;
}

int cmp(const void *a, const void *b)
{
ROAD *x = (ROAD *)a;
ROAD *y = (ROAD *)b;
return (x->d > y->d) ? 1 : -1;
}

int main(void)
{
int m, i, j;
POINT p[N+1];
ROAD r[M];
double sum;

while (scanf("%d", &n) != EOF && n)
{
for (i=1; i<=n; i++)
scanf("%lf%lf", &p[i].x, &p[i].y);

m = 0;
for (i=1; i<=n; i++)
{
for (j=i+1; j<=n; j++)
{
r[m].x = i;
r[m].y = j;
r[m].d = sqrt( (p[i].x-p[j].x)*(p[i].x-p[j].x)
+ (p[i].y-p[j].y)*(p[i].y-p[j].y) );
m ++;
}
}
qsort(r, m, sizeof(r[0]), cmp);
//for (i=0; i<m; i++)
//  printf("%d %d %.2lf\n", r[i].x, r[i].y, r[i].d);

init();
sum = 0;
for(i=0; i<m; i++)
{
if(combine(r[i].x, r[i].y))
sum += r[i].d;
if (num == 1)
break;
}

printf("%.2lf\n", sum);
}

return 0;
}
/**************************************************************
Problem: 1144
User: liangrx06
Language: C
Result: Accepted
Time:10 ms
Memory:932 kb
****************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: