您的位置:首页 > 其它

[sicily]1087. A Funny Game

2015-10-23 21:22 435 查看


1087. A Funny Game


Constraints

Time Limit: 1 secs, Memory Limit: 32 MB


Description

Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 106) coins in a circle, as Figure 1 shows. A move consists in removing one or twoadjacent coins,
leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)

                                   
                                       Figure 1
Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent!
(Because there is an empty place between c1 and c3.)

Suppose that both Alice and Bob do their best in the game. 

You are to write a program to determine who will finally win the game. 


Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.


Output

For each test case, if Alice win the game,output "Alice", otherwise output "Bob".


Sample Input


1
2
3
0


Sample Output


Alice
Alice
Bob


有趣的策略题。当n > 2时,Alice取完第一次,Bob总是可以使得环分拆成对称的两段,接下来Alice随便取,只要Bob在另一段中跟Alice做相同取法,继续保持剩下来的对称,便可以确保取胜。故,当n > 2,Bob必胜。

#include <iostream>
using namespace std;

int main()
{
int n;
while(cin>>n && n>0)
{
if(n>2)
cout<<"Bob"<<endl;
else
cout<<"Alice"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  sicily