您的位置:首页 > 其它

Uva624 CD (记录路径)

2015-10-23 16:37 375 查看
CD

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

Assumptions:

number of tracks on the CD. does not exceed 20

no track is longer than N minutes

tracks do not repeat

length of each track is expressed as an integer number

N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input

Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output

Set of tracks (and durations) which are the correct solutions and string “sum:” and sum of duration times.

Sample Input

5 3 1 3 4

10 4 9 8 4 2

20 4 10 5 7 4

90 8 10 23 1 2 3 4 5 7

45 8 4 10 44 43 12 9 8 2

Sample Output

1 4 sum:5

8 2 sum:10

10 5 4 sum:19

10 23 1 2 3 4 5 7 sum:55

4 10 12 9 8 2 sum:45

实质是价值与重量相等的背包,但难点是打印路径,想了好久都不会,最后还是参考了一下别人的代码,一下就懂了,看来我还是有很长的路要走

从后往前记录

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <algorithm>

using namespace std;

int main()
{
int i,j;
int cd[25];
int n,t;
int dp[1500],path[25][1500];
while(scanf("%d",&n)!=EOF)
{
scanf("%d",&t);
memset(path,0,sizeof(path));
memset(dp,0,sizeof(dp));
for(i=1;i<=t;i++)
{
scanf("%d",&cd[i]);
}
for(i=t;i>=1;i--)
{
for(j=n;j>=cd[i];j--)
{
if(dp[j]<dp[j-cd[i]]+cd[i])
{
dp[j]=dp[j-cd[i]]+cd[i];
path[i][j]=1;
}

}
}

for(i=1,j=n;i<=t;i++)
{
if(path[i][j])
{
printf("%d ",cd[i]);
j-=cd[i];
}
}
printf("sum:%d\n",dp
);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: