您的位置:首页 > 产品设计 > UI/UE

*杭电1005——Number Sequence(数学题)

2015-10-22 17:12 447 查看
Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

5

看到题目,一开始用的递归,因为n过大,肯定会发生栈溢出。后来尝试用数组从小到大一个一个计算,开一个100,000,000的数组超过了题目设置的内存大小。然后,百度了下,因为有mod7,所以f(n-1)和f(n-2)的值只有7种,即为0~6.f
的值在最多在f[49] 7*7=49之后会出现重复。(为什么最多49个元素后面出现循环,即第49~97个元素与第1~48个元素一一对应相等,为什么是49明白,但是为什么出现循环就不太清楚~~~)

# include<stdio.h>
int f[50];

int main()
{
int A,B,n;
while(1)
{
scanf("%d%d%d",&A,&B,&n);
if(A==0&&B==0&&n==0)
break;
else
{
int i;
f[1]=1;
f[2]=1;
for(i=3;i<=49;i++)
{
f[i]=(A*f[i-1]+B*f[i-2])%7;
if(f[i]==1&&f[i-1]==1) break;//进入下一次循环,i-2即为一次循环元素的个数(最大为49)
}
n=n%(i-2);
if(n==0) printf("%d\n",f[i-2]);
else
printf("%d\n",f
);
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: