您的位置:首页 > 其它

HDU 4901 The Romantic Hero

2015-10-22 16:13 417 查看

The Romantic Hero

Time Limit: 3000ms
Memory Limit: 131072KB
This problem will be judged on HDU. Original ID: 4901
64-bit integer IO format: %I64d Java class name: Main

There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

You may wonder why this country has such an interesting tradition? It has a very long story, but I won't tell you :).

Let us continue, the party princess's knight win the algorithm contest. When the devil hears about that, she decided to take some action.

But before that, there is another party arose recently, the 'MengMengDa' party, everyone in this party feel everything is 'MengMengDa' and acts like a 'MengMengDa' guy.

While they are very pleased about that, it brings many people in this kingdom troubles. So they decided to stop them.

Our hero z*p come again, actually he is very good at Algorithm contest, so he invites the leader of the 'MengMengda' party xiaod*o to compete in an algorithm contest.

As z*p is both handsome and talkative, he has many girl friends to deal with, on the contest day, he find he has 3 dating to complete and have no time to compete, so he let you to solve the problems for him.

And the easiest problem in this contest is like that:

There is n number a_1,a_2,...,a_n on the line. You can choose two set S(a_s1,a_s2,..,a_sk) and T(a_t1,a_t2,...,a_tm). Each element in S should be at the left of every element in T.(si < tj for all i,j). S and T shouldn't be empty.

And what we want is the bitwise XOR of each element in S is equal to the bitwise AND of each element in T.

How many ways are there to choose such two sets? You should output the result modulo 10^9+7.

Input

The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n which are separated by a single space.

n<=103, 0 <= a_i <1024, T<=20.

Output

For each test case, output the result in one line.

Sample Input

2
3
1 2 3
4
1 2 3 3

Sample Output

1
4

Source

2014 Multi-University Training Contest 4

解题:动态规划
由于有重复情况存在,需要强制选择划分的那个元素,所以有dp[i][j][0]表示前i个的异或和为j,且第i个不选的方案数
dp[i][j][1]则表示前i个异或和为j且必选第i个的方案数
dp2[i][j]表示从i开始,后面随便选几个与和为j的方案数
那么答案就是
\[\sum_{i=1}^{n-1}\sum_{j=0}^{1023}dp[i][j][1]*dp2[i+1][j]\]

#include <bits/stdc++.h>
using LL = long long;
using namespace std;
const int maxn = 1010;
const LL mod = 1e9 + 7;
LL dp[maxn][1024][2],dp2[maxn][1024];
int n,a[maxn];
int main(){
int kase;
scanf("%d",&kase);
while(kase--){
memset(dp,0,sizeof dp);
memset(dp2,0,sizeof dp2);
scanf("%d",&n);
for(int i = 1; i <= n; ++i) scanf("%d",a + i);
dp[1][a[1]][1] = 1;
for(int i = 2; i <= n; ++i){
dp[i][a[i]][1]++;
for(int j = 0; j < 1024; ++j){
dp[i][j][0] += dp[i-1][j][0] + dp[i-1][j][1];
dp[i][j^a[i]][1] += dp[i-1][j][0] + dp[i-1][j][1];
dp[i][j][0] %= mod;
dp[i][j^a[i]][1] %= mod;
}
}
dp2
[a
] = 1;
for(int i = n-1; i > 0; --i){
dp2[i][a[i]]++;
for(int j = 0; j < 1024; ++j){
dp2[i][j] += dp2[i+1][j];
dp2[i][j&a[i]] += dp2[i+1][j];
dp2[i][j] %= mod;
dp2[i][j&a[i]] %= mod;
}
}
LL ret = 0;
for(int i = 1; i < n; ++i)
for(int j = 0; j < 1024; ++j)
ret = (ret + dp[i][j][1]*dp2[i+1][j])%mod;
printf("%I64d\n",ret);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: