您的位置:首页 > 产品设计 > UI/UE

【PAT】 1085. Perfect Sequence (25)

2015-10-22 14:16 399 查看
Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the
parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

分析:(1)int*int有可能会超出int范围,所以用long long (2)使用二分查找法,否则会超时

代码如下:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

//vec 采用“引用”则不会超时,如果用传参则会超时。
int binaryFind(vector<long long >& vec, long long max, int i){
int left = i;
int right = vec.size()-1;
int mid;
while(left < right){
mid = (left+right)/2;
if(vec[mid] > max){
right = mid - 1;
}else if(vec[mid] < max){
left = mid + 1;
}else{
return mid;
}
}
return vec[left]>max? left-1:left;
}

int main(int argc, char** argv) {
long long n, p, i, val;
scanf("%lld%lld",&n,&p);
vector<long long> vec(n);
for(i=0; i<n; i++){
scanf("%lld",&vec[i]);
}
sort(vec.begin(), vec.end());
long long max;
int cnt=0, pos;
for(i=0; i<n; i++){
max = p*vec[i];
pos = binaryFind(vec, max, i);
if(pos-i+1 > cnt){
cnt = pos-i+1;
}
}
printf("%d\n",cnt);
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT 二分查找