您的位置:首页 > 其它

hdu 4764 Stone

2015-10-22 12:16 357 查看


Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1156    Accepted Submission(s): 807


Problem Description

Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming
that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number
only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.

 

Input

There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.

 

Output

For each case, print the winner's name in a single line.

 

Sample Input

1 1
30 3
10 2
0 0

 

Sample Output

Jiang
Tang
Jiang

 

Source

2013 ACM/ICPC Asia Regional Changchun Online

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  5508 5507 5506 5505 5504 

首先N、k 都为正整数。

如果N是一,则第一个放的人输。

如果 2<=N&&N<=K+1,第一个人赢。

其他情况:能够把子放到N-1 位置的必胜。如果要保证把子能放到n-1,必须要保证把子放到n-1-(k+1),多次减,如果胜利等价于放到位置1到k,那么先放的人获胜,如果是位置k+1,那么后放的人胜。

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<cctype>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI 3.1415926535897932384626
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   num<<1,le,mid
#define rson    num<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second
using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
//const int maxm=    ;

int n,k;

int  work()
{
if(n==1) return 2;
if(2<=n&&n<=k+1) return 1;
int t=(n-1)/(k+1);
int y=n-1-t*(k+1);
if(y==0) return 2;//k+1
return 1;
}
int main()
{
while(~scanf("%d%d",&n,&k)&&(n||k))
{
int ans=work();
if(ans==1)   puts("Tang");
else puts("Jiang");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: