您的位置:首页 > 其它

杭电oj-1040-As Easy As A+B

2015-10-21 21:54 411 查看
Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in
the same line.

It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

2

3 2 1 3

9 1 4 7 2 5 8 3 6 9

Sample Output

1 2 3
1 2 3 4 5 6 7 8 9

这道题的意思是给你一个数c,然后有c个样例,然后每个样例都先输入一个数n,然后有n个数,让你把这n个数按升序排列并输出

这道题并没有什么坑点,纯粹的一道简单题,sort即可解决

代码如下

#include <iostream>

#include<string.h>

#include<stdio.h>

#include<algorithm>

#include <stdio.h>

using namespace std;

int main()

{

    int a[2000],c,n;

    while(scanf("%d",&c)!=EOF)

    {

        while(c--)

        {

            scanf("%d",&n);

            for(int i=0;i<n;i++)

                scanf("%d",&a[i]);

            sort(a,a+n);

            printf("%d",a[0]);

            for(int i=1;i<n;i++)

                printf(" %d",a[i]);

            printf("\n");

        }

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: