您的位置:首页 > 其它

poj 2105 IP Address

2015-10-20 23:28 447 查看
原题链接:http://poj.org/problem?id=2105

IP Address

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 19317Accepted: 11156
Description

Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at
a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary
systems are:

27   26  25  24  23   22  21  20

128 64  32  16  8   4   2   1


Input

The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.
Output

The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.
Sample Input
4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001

Sample Output
0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1

Source

México and Central America 2004

题意:根据32位二进制01代码,转化为4段十进制IP地址(每八位二进制对应一个十进制)

附上AC代码:

#include <stdio.h>
#include <math.h>
int main()
{
int i,n,sum;
char a[35];
scanf("%d",&n);
getchar();//消除回车,否则对下面的字符串有影响
while(n--)
{
gets(a);
sum=0;
for (i=0;i<32;i++)
{
if (a[i]=='1')
{
sum+=pow(2,(7-i%8));//循环,标准二进制转十进制
}

if ((i+1)%8==0&&i!=0)
{
if (i==31)
{
printf("%d\n",sum);
}
else
{
printf("%d.",sum);
}
sum=0;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: