您的位置:首页 > 其它

POJ 2367 Genealogical tree

2015-10-20 23:23 246 查看
Genealogical tree

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 3934Accepted: 2605Special Judge
Description
The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will
be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than
to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake
first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input
The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural
numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may
be empty. The list (even if it is empty) ends with 0.
Output
The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least
one such sequence always exists.
Sample Input
5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output
2 4 5 3 1

Source

拓扑排序裸题。

最近看了一道TopCoder的题,貌似要用到拓扑排序。

便找了一道拓扑排序入门题先练习了一下。下次把那道题放上来。

这道题,根据输入建立临街矩阵,记录各点的入度。

之后循环找到度为0的点,记录下来。

图中和此点相连的点的度都减1即可。

最后把记录下来的点按照顺序输出。

最近把系统环境搬到Ubuntu下了。

发现Ubuntu下的控制台并不能复制粘贴网页里的数据。

于是打算开始使freopen了,发现还挺好用的。

#include <stdio.h>
#include <string.h>
#define N 105
int degree
;
int graph

;
int ans
;
int n;
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d",&n)>0)
{
memset(degree,0,sizeof(degree));
memset(graph,0,sizeof(graph));
for(int i=1;i<=n;i++)
{
int temp;
while(scanf("%d",&temp)>0&&temp)
{
graph[i][temp]=1;
degree[temp]++;
}
}
int pos=-1;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
if(degree[j]==0)
{
pos=j;
break;
}
degree[pos]=-1;
ans[i]=pos;
for(int j=1;j<=n;j++)
if(graph[pos][j])
degree[j]--;
}
printf("%d",ans[1]);
for(int i=2;i<=n;i++)
printf(" %d",ans[i]);
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: