您的位置:首页 > 其它

九度OJ 1036:Old Bill (老比尔) (基础题)

2015-10-18 16:51 399 查看
时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:2691

解决:1432

题目描述:

Among grandfather's papers a bill was found.

72 turkeys $_679_

The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are illegible. What are the two faded digits and what was the price of one turkey?

We want to write a program that solves a general version of the above problem.

N turkeys $_XYZ_

The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkeys is an
integer number of dollars, and that all the

turkeys cost the same price.

Given N, X, Y, and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two
faded digits and the maximum price per turkey for the turkeys.

输入:

The first line of the input file contains an integer N (0<N<100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y, and Z., separated by a space, of the original price $_XYZ_.

输出:

For each case, output the two faded digits and the maximum price per turkey for the turkeys.

样例输入:
72
6 7 9
5
2 3 7
78
0 0 5


样例输出:
3 2 511
9 5 18475
0


来源:2007年上海交通大学计算机研究生机试真题

思路:

比较简单,万位和个位循环尝试即可。

代码:

#include <stdio.h>

#define N 100

int main(void)
{
int n, i, j, num;
int x, y, z, xyz0;

while (scanf("%d", &n) != EOF)
{
scanf("%d%d%d", &x, &y ,&z);
xyz0 = x*1000 + y*100 +z*10;

int find = 0;
for (i=9; i>0; i--)
{
for (j=9; j>=0; j--)
{
num = i*10000 + xyz0 + j;
if (num % n == 0)
{
printf("%d %d %d\n", i, j, num/n);
find = 1;
break;
}
}
if (find == 1)
break;
}
if (find == 0)
printf("0\n");
}

return 0;
}
/**************************************************************
Problem: 1036
User: liangrx06
Language: C
Result: Accepted
Time:0 ms
Memory:912 kb
****************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: