您的位置:首页 > 产品设计 > UI/UE

Advanced Fruits(合并字符串+最长公共子序列应用)hdu1503 +动态规划

2015-10-17 21:18 471 查看


Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768
K (Java/Others)
Total Submission(s): 2173    Accepted Submission(s): 1109
Special Judge

Problem Description

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like
a mixture between both of them. 

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string
that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 

 

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file. 

 

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

 

Sample Input

apple peach
ananas banana
pear peach

 

Sample Output

appleach
bananas
pearch

 

Source

University of Ulm Local Contest 1999

 

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1503

题意:将两个字符串结合起来,他们的公共子串只输出一次

思路:根据LCS的原理,将每个字符都进行标记,看两个字符串中对应的字符究竟处于什么状态,

然后输出,其标记为公共子串的字符只输出一次即可,也是一道模板题   详细方法见代码。

关于
>>最长公共子序列<< 链接

#include<cstring>
#include<cstdio>
#include<iostream>
using namespace std;

/***
题意:将两个字符串结合起来,他们的公共子串只输出一次

思路:根据LCS的原理,将每个字符都进行标记,看两个字符串中对应的字符究竟处于什么状态,

然后输出,其标记为公共子串的字符只输出一次即可,也是一道模板题
*/

int map[1005][1005];
string str1,str2;
/**方案一:利用vis记录返回的路径*/
/*
int vis[1005][1005];
void LCS(int len1,int len2)
{
// memset(vis,0,sizeof(vis));
for(int i=0;i<len1;i++) {map[i][0]=0; vis[i][0]=1;}
for(int j=0;j<len2;j++) {map[0][j]=0; vis[0][j]=-1;}
for(int i=1;i<=len1;i++)
{
for(int j=1;j<=len2;j++)
{
if(str1[i-1]==str2[j-1]){ map[i][j]=map[i-1][j-1]+1; vis[i][j]=0;}
else if(map[i-1][j]>=map[i][j-1]){ map[i][j]=map[i-1][j]; vis[i][j]=1;}
else { map[i][j]=map[i][j-1]; vis[i][j]=-1; }
}
}
}
void Print(int i,int j)
{
// printf("-------\n");
if(i==0 && j==0) return ;
if(vis[i][j]==0)
{
Print(i-1,j-1);
printf("%c",str1[i-1]);
}
else if(vis[i][j]==1)
{
Print(i-1,j);
printf("%c",str1[i-1]);
}
else
{
Print(i,j-1);
printf("%c",str2[j-1]);
}
}*/
/***方案二:利用map本身的变化,找路径
规律是根据map[i][j] 与map[i-1][j-1]、map[i-1][j]、map[i][j-1]的关系来确定
具体来说:map[i-1][j-1]==map[i-1][j]==map[i][j-1] && map[i][j]==map[i-1][j-1]+1;表示共同点
可以通过观察map[][]来发现!
*/
void LCS(int len1,int len2)
{
for(int i=0;i<=len1;i++)
{
for(int j=0;j<=len2;j++)
{
if(i==0||j==0) {map[i][j]=0; continue;}
if(str1[i-1]==str2[j-1]){ map[i][j]=map[i-1][j-1]+1;}
else if(map[i-1][j]>=map[i][j-1]){ map[i][j]=map[i-1][j];}
else { map[i][j]=map[i][j-1]; }
}
}
}
void Print(int i,int j)
{
// printf("-------\n");
if(i==0 && j==0) return ;
if(map[i][j]==map[i-1][j-1]+1 && map[i-1][j]==map[i][j-1] && map[i-1][j-1]==map[i-1][j])
{
Print(i-1,j-1);
printf("%c",str1[i-1]);
}
else if(map[i][j]==map[i-1][j])
{
Print(i-1,j);
printf("%c",str1[i-1]);
}
else
{
Print(i,j-1);
printf("%c",str2[j-1]);
}
}
int main()
{
while(cin>>str1>>str2)
{
int len1=str1.length();
int len2=str2.length();
LCS(len1,len2);
/**
for(int i=0;i<=len1;i++)
{
for(int j=0;j<=len2;j++)
{
printf("%d\t",vis[i][j]);
}
printf("\n");
}
*//**
for(int i=0;i<=len1;i++)
{
for(int j=0;j<=len2;j++)
{
printf("%d\t",map[i][j]);
}
printf("\n");
}
*/
Print(len1,len2);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息