您的位置:首页 > 其它

hdoj Reorder the Books 5500 (技巧) 好题

2015-10-17 13:52 232 查看

Reorder the Books

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 508    Accepted Submission(s): 328


[align=left]Problem Description[/align]
dxy has a collection of a series of books called "The Stories of SDOI",There aren(n≤19)
books in this series.Every book has a number from
1
to n.

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing
himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.

[align=left]Input[/align]
There are several testcases.

There is an positive integer T(T≤30)
in the first line standing for the number of testcases.

For each testcase, there is an positive integer n
in the first line standing for the number of books in this series.

Followed n
positive integers separated by space standing for the order of the disordered books,theith
integer stands for the ith
book's number(from top to bottom).

Hint:

For the first testcase:Moving in the order of book3,book2,book1
,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4),and
this is the best way to reorder the books.

For the second testcase:It's already ordered so there is no operation needed.

[align=left]Output[/align]
For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.

[align=left]Sample Input[/align]

2
4
4 1 2 3
5
1 2 3 4 5

[align=left]Sample Output[/align]

3
0//看到这个题感觉好难,想了好多,还是不会。但没想到大神的代码可以如此精简,智商有一次被打压了。
#include<stdio.h>
#include<string.h>
int main()
{
int a[20];
int t,n,m,i,sum;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
if(a[i]==n)
m=i;
}
int sum=n;
for(i=m;i>=0;i--)
if(a[i]==sum)
sum--;
printf("%d\n",sum);
}
return 0;
}
//再写一次,感觉不一样了
#include<stdio.h>
#include<string.h>
int a[20];
int main()
{
int t,n,i,j,k,num;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
num=n;
for(k=n;k>0;k--)
{
if(a[k]==num)
num--;
}
printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: