您的位置:首页 > 其它

POJ1007 DNA Sorting

2015-10-17 11:26 295 查看
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
#include<iostream>
#include<string>
using namespace std;
int main()
{
int n, m;
cin >> n >> m;//m表示行  n表示列
//char **a = new char *[m];//动态创建行数
//for (int i = 0; i < m; i++)//动态创建列数
//{
// a[i] = new char
;
//}
int *countLine = new int[m];
string *str = new string[m];
for (int i = 0; i < m; i++)
{
cin >> str[i];
countLine[i] = 0;
}

for (int i = 0; i < m; i++)//每一行
{
for (int k = 0; k < n; k++)
{
char temp = str[i][k];
for (int j = k; j < n; j++)//判断这一行的字母有几个小于该字母的
{
if (temp>str[i][j])
{
countLine[i]++;
}
}
}
}
for (int i = 1; i < m; i++)
{
for (int j = 0; j < m-i; j++)
{
if (countLine[j] > countLine[j + 1])
{
int temp = countLine[j];
countLine[j] = countLine[j + 1];
countLine[j + 1] = temp;
string tempStr = str[j];
str[j] = str[j + 1];
str[j + 1] = tempStr;
}
}
}
for (int i = 0; i < m; i++)
{
cout << str[i] << endl;
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ