您的位置:首页 > 其它

UVA - 1600 Patrol Robot

2015-10-16 19:17 274 查看
Description





A robot has to patrol around a rectangular area which is in a form of mxn grid (m rows and n columns).
The rows are labeled from 1 to m. The columns are labeled from 1 to n. A cell (i, j) denotes the cell in row i and
column j in the grid. At each step, the robot can only move from one cell to an adjacent cell, i.e. from (x, y) to (x + 1, y), (x, y +
1), (x - 1, y) or (x, y - 1). Some of the cells in the grid contain obstacles. In order to move to a cell containing obstacle, the robot has to switch to turbo mode.
Therefore, the robot cannot move continuously to more than k cells containing obstacles.
Your task is to write a program to find the shortest path (with the minimum number of cells) from cell (1, 1) to cell (m, n). It is assumed that both these cells do
not contain obstacles.

Input

The input consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.
For each data set, the first line contains two positive integer numbers m and n separated by space (1

m, n

20).
The second line contains an integer number k(0

k

20).
The ith line of the next m lines contains n integer aij separated by space (i =
1, 2,..., m;j = 1, 2,..., n). The value of aij is 1 if there is an obstacle on the cell (i, j), and is 0 otherwise.

Output

For each data set, if there exists a way for the robot to reach the cell (m, n), write in one line the integer number s, which is
the number of moves the robot has to make; -1 otherwise.

Sample Input

3
2 5
0
0 1 0 0 0
0 0 0 1 0
4 6
1
0 1 1 0 0 0
0 0 1 0 1 1
0 1 1 1 1 0
0 1 1 1 0 0
2 2
0
0 1
1 0


Sample Output

7
10
-1


分析:这题是典型的BFS迷宫最短路问题,但是有个坑点,注意一句话:Therefore, the robot cannot move continuously to more than k cells
containing obstacles. 意思是不能连续移动超过k个障碍格子,移动是可选择的,我开始以为只能一次性移动,要么穿过所有障碍要么过不去。 明白这一点后就很好做了,只需要加一个状态量即可。

#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
struct Node {
int r, c, k;
Node(int r=0, int c=0, int k=0):r(r),c(c),k(k) {}
};
const int maxn = 23;
const int dr[] = { 0, 1, 0, -1};
const int dc[] = { 1, 0, -1, 0};
int G[maxn][maxn];
int D[maxn][maxn][maxn];
int m, n, k;

bool inside(const Node& v) {
return v.r>=1&&v.r<=m && v.c>=1&&v.c<=n;
}

int solve() {
memset(D, -1, sizeof(D));
D[1][1][k] = 0;
queue<Node> q;
q.push(Node(1,1,k));
while(!q.empty()) {
Node u = q.front(); q.pop();
if(u.r==m && u.c==n) return D[m]
[k];
for(int i=0; i<4; i++) {
Node v = u;
v.r += dr[i];
v.c += dc[i];
if(G[v.r][v.c]) v.k--;
else v.k = k;
if(inside(v) && v.k>=0 && D[v.r][v.c][v.k]<0) {
D[v.r][v.c][v.k] = D[u.r][u.c][u.k] + 1;
q.push(v);
}
}
}
return -1;
}

int main()
{
int T;
scanf("%d",&T);
while(T--) {
scanf("%d%d%d",&m,&n,&k);
for(int i=1; i<=m; i++) {
for(int j=1; j<=n; j++) {
scanf("%d",&G[i][j]);
}
}
printf("%d\n",solve());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: