您的位置:首页 > 其它

POJ 2393 Yogurt factory(贪心 or DP)

2015-10-15 20:05 369 查看
Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of
yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any
yogurt already in storage, can be used to meet Yucky's demand for that week.
Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.
Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.
Sample Input
4 5
88 200
89 400
97 300
91 500

Sample Output
126900

题意:
一公司生产牛奶,每周生产的价格为Ci,每周需要上交的牛奶量Yi,你可以选择本周生产牛奶,也可选择提前几周生产出存储在仓库中(仓库无限大,而且保质期不考虑),每一周存仓库牛奶需要花费S元,让你求出所有周的需求量上交的最少花费。

解题思路:
当第 j 周牛奶的造价 Ci 大于第 i 周的造价加上 (j - i) 周的储藏费时,就使用第 i 周的,否则使用第 j 周的。

注意结果用long long存。

#include <iostream>
using namespace std;

struct node
{
int c,y;
}week[10002];

int main(int argc, char const *argv[])
{
int N,S;
while(cin >> N >> S)
{
for(int i = 0;i < N;i++)
cin >> week[i].c >> week[i].y;

long long cost = 0;
for(int i = 0;i < N;i++)
{
int temp = i,Y = 0;
long long save = 0;
for(int j = temp;j < N && week[j].c - week[temp].c >= S*(j-temp);j++)
{
Y += week[j].y;
save += (Y-week[temp].y)*S;
i = j;
}
cost += Y*week[temp].c+save;
}
cout << cost << endl;
}
return 0;
}

也有人用DP做的。在第i周时,有2种选择:

1. C[i]*F[i];   用当前的

2. (C[j]+(i-j)*S)*F[i]   1<=j<i; 用以前的

当j=i,(C[j]+(i-j)*S)*F[i]=C[i]*F[i];

所以就是 (C[j]+(i-j)*S)*F[i]=(C[j]-j*S+i*S)*F[i]   1<=j<=i;

所以只需求出C[j]-j*S的最小值就可以了,循环时记录最小值就可以了。

等刷到DP的时候再拿出来做一下。

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 贪心 DP