您的位置:首页 > 其它

nyoj 220 推桌子

2015-10-15 16:13 411 查看


推桌子

时间限制:1000 ms  |  内存限制:65535 KB
难度:3

描述The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

输入The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables
to move. 

Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 

line, the remaining test cases are listed in the same manner as above.
输出The output should contain the minimum time in minutes to complete the moving, one per line.
样例输入
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50


样例输出
10
20
30


贪心:这道题是选择不相交区间问题,要注意把实际问题建模成为基本问题,如房间3和房间4都应“加一除二”转化为2,还要注意输入的两个开始结束值不一定是按大小顺序排列的!


按开始时间升序排列,从i=0开始遍历,首先找到未visit的区间,如果找到,则num+=10(指的是i可以安排在此会场,后面就开始寻找和这个区间能够同时搬运的区间),保留第i个区间的结束处last,然后嵌套遍历,j从i+1到n-1,若第j个区间的开始大于last,则在这10分钟内可以同时用第j个区间,修改last,标记第j个区间为已经visit。


代码:


#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace  std;
struct line//
{
int bg;
int ed;
int vis;
}num[1010];
int cmp(line x,line y)//按开始排序
{
if(x.bg ==y.bg )
return x.ed <y.ed ;
return x.bg <y.bg ;
}

int main()
{
int n,k,a,b;
scanf("%d",&n);
while(n--)
{
int m,c;
scanf("%d",&m);
memset(num,0,sizeof(num));
for(int i=0;i<m;i++)
{
scanf("%d%d",&a,&b );
if(a>b)//将顺序调整
{
c=b;
b=a;
a=c;
}
num[i].bg =(a+1)/2;//根据题意建立实际模型
num[i].ed =(b+1)/2;
}
sort(num,num+m,cmp);
int count=0;
for(int i=0;i<m;i++)
{
if(!num[i].vis )
{
count+=10;
int end=num[i].ed ;
for(int j=i+1;j<m;j++)
{
if(!num[j].vis &&num[j].bg >end)
{
num[j].vis =1;
end=num[j].ed;
}
}
}
}
printf("%d\n",count);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  nyoj 220 推桌子 贪心