您的位置:首页 > 理论基础 > 数据结构算法

Just a Hook(线段树,区间更新)

2015-10-15 12:52 459 查看
A - Just a Hook
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
1698

Appoint description: 
System Crawler  (2015-10-10)

Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. 



Now Pudge wants to do some operations on the hook. 

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. 

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: 

For each cupreous stick, the value is 1. 

For each silver stick, the value is 2. 

For each golden stick, the value is 3. 

Pudge wants to know the total value of the hook after performing the operations. 

You may consider the original hook is made up of cupreous sticks. 

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. 

For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. 

Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents
the golden kind. 

 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 

 

Sample Input

1
10
2
1 5 2
5 9 3

 

Sample Output

Case 1: The total value of the hook is 24.

一开始没用延迟标记,结果TLE了。而想用标记优化时才发现我不会做,结果看了看别人代码后发现好多都好复杂,都不易看懂,找了很久才找到一篇比较适合新手的题解。 思路: 这题不是区间的增值与减值的题,所以比较简单,所有的区间值都是在更新的时候不计算值的,所以问题就来了。我们只要处理好标记就行了。只要符合所需要的区间,那个点就更新标记,这样就将点的单价给出来了。
TLE代码:
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<cmath>
#include<map>
using namespace std;
#define T 100005
#define inf 0x3f3f3f3f
#define CRL(a) memset(a,0,sizeof(a))
typedef long long ll;
struct node
{
int v,l,r,mid;
}tree[T<<2];
void PushUp(int rt)
{
tree[rt].v = tree[rt<<1].v+tree[rt<<1|1].v;
}
void Build(int rt,int L,int R)
{
tree[rt].l=L,tree[rt].r=R;
tree[rt].v=0;
tree[rt].mid = (L+R)>>1;
if(L==R){
tree[rt].v=1;
return;
}
Build(rt<<1,L,tree[rt].mid);
Build(rt<<1|1,tree[rt].mid+1,R);
PushUp(rt);
}
void add(int rt,int L,int R,int v)
{
if(tree[rt].l==tree[rt].r){
tree[rt].v=v;
return;
}
if(R<=tree[rt].mid){
add(rt<<1,L,R,v);
}
else if(L>tree[rt].mid)
{
add(rt<<1|1,L,R,v);
}
else
{
add(rt<<1,L,tree[rt].mid,v);
add(rt<<1|1,tree[rt].mid+1,R,v);
}
PushUp(rt);
}
int main()
{
/*freopen("input.txt","r",stdin);*/
int N,n,m,i,j,k,v,c=0;
scanf("%d",&N);
while(N--)
{
scanf("%d %d",&n,&m);
Build(1,1,n);
for(i=1;i<=m;++i){
scanf("%d%d%d",&j,&k,&v);
add(1,j,k,v);
}
printf("Case %d: The total value of the hook is %d.\n",++c,tree[1].v);
}
return 0;
}


AC代码:
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<cmath>
#include<map>
using namespace std;
#define T 100005
#define inf 0x3f3f3f3f
#define CRL(a) memset(a,0,sizeof(a))
typedef long long ll;
struct node
{
int v,l,r,mid;
}tree[T<<2];
void PushDown(int rt)
{
tree[rt<<1].v=tree[rt<<1|1].v=tree[rt].v;
tree[rt].v=-1;
}
void Build(int rt,int L,int R)
{
tree[rt].l=L,tree[rt].r=R;tree[rt].mid = (L+R)>>1;
tree[rt].v=1;
if(L==R){return;}
Build(rt<<1,L,tree[rt].mid);
Build(rt<<1|1,tree[rt].mid+1,R);
}
void add(int rt,int L,int R,int v)
{
if(tree[rt].l>=L&&tree[rt].r<=R){
tree[rt].v=v;return;
}
if(tree[rt].v!=-1)
PushDown(rt);
if(R<=tree[rt].mid){
add(rt<<1,L,R,v);
}
else if(L>tree[rt].mid)
{
add(rt<<1|1,L,R,v);
}
else
{
add(rt<<1,L,tree[rt].mid,v);
add(rt<<1|1,tree[rt].mid+1,R,v);
}
}
int find(int rt)
{
if(tree[rt].v!=-1)
return tree[rt].v*(tree[rt].r-tree[rt].l+1);
else
return find(rt<<1)+find(rt<<1|1);
}
int main()
{
/*freopen("input.txt","r",stdin);*/
int N,n,m,i,j,k,v,c=0;
scanf("%d",&N);
while(N--)
{
scanf("%d %d",&n,&m);
Build(1,1,n);
for(i=1;i<=m;++i){
scanf("%d%d%d",&j,&k,&v);
add(1,j,k,v);
}
printf("Case %d: The total value of the hook is %d.\n",++c,find(1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 线段树