您的位置:首页 > 其它

hdu1018Big number(N!的位数-斯特林公式)

2015-10-14 22:06 316 查看

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31557    Accepted Submission(s): 14695


[align=left]Problem Description[/align]
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of
digits in the factorial of the number.

 

[align=left]Input[/align]
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

 

[align=left]Output[/align]
The output contains the number of digits in the factorial of the integers appearing in the input.

 

[align=left]Sample Input[/align]

2
10
20

 

[align=left]Sample Output[/align]

7
19

 题目大意:给你个数N,求N的阶乘的位数?
解题思路:首先已知,一个数N的位数我们可用 log10(N) + 1求出;显然N!的位数在N非常大时是不能用一般方法解决的。
这里就要用到斯特林公式:
N!= sqrt (2*3.1415926*n)*(n/e)^n  即下面的公式:



那么就可以利用这个公式计算出N!的位数为:
num(N!) = log10 (2*sqrt(acos(-1.0)*N) + N*log10(N) - N*log(exp(1.0)) +1 ;
其中:log10() 、acos(x) 、exp(x).均为c语言的库函数,
log10(double x)      求以10为底X的对数。
acos(double x)       求余弦的反函数的值。
exp(double x)         求指数e^x的值。
那么代码就是:
#include<stdio.h>
#include<math.h>
int main()
{
double n;
int t,i,j;
scanf("%d",&t);
while(t--)
{
int num=0;
scanf("%lf",&n);
num=log10(sqrt(2*acos(-1.0)*n)) + n*log10(n) - n*log10(exp(1.0));
printf("%d\n",num+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: