您的位置:首页 > 其它

[PAT (Advanced Level) ]1027. Colors in Mars 解题文档

2015-10-14 16:25 363 查看


1027. Colors in Mars (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference
is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values. 

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left. 
Sample Input
15 43 71


Sample Output
#123456


分析:

此题没有难度,按要求转换成13进制即可。

C++代码如下。

#include<iostream>
#include<string>
#include<strstream>
using namespace std;
#define RADIX 13

string trans(int N){
string result="";
int a=N/RADIX;
string temp;
if(a<=9){
strstream ss;
ss<<a;
ss>>temp;
}
else if(a>9){
if(a==10)
temp="A";
else if(a==11)
temp="B";
else if(a==12)
temp="C";
}
result+=temp;
int b=N%RADIX;
if(b<=9){
strstream ss;
ss<<b;
ss>>temp;
}
else if(b>9){
if(b==10)
temp="A";
else if(b==11)
temp="B";
else if(b==12)
temp="C";
}
result+=temp;
return result;
}

int main(){
int a[3];
for(int i=0;i<3;i++){
cin>>a[i];
}
cout<<"#"<<trans(a[0])<<trans(a[1])<<trans(a[2]);
return 0;
}


所有测试点均已通过。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: