您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2015-10-13 21:12 381 查看


1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


第一次写,部分案例通过:

#include<stdio.h>

int main(){
int k,n;
double a;
int i;
while(scanf("%d",&k)!=EOF){

double arr[1001];
int num = 0;
for(i=0;i<1001;i++){
arr[i] = 0;
}
for(i=0;i<k;i++){
scanf("%d %lf",&n,&a);
arr
= arr
+a;
num++;
}
scanf("%d",&k);
for(i=0;i<k;i++){
scanf("%d %lf",&n,&a);
if(arr
==0)
num++;
arr
= arr
+a;
}

printf("%d",num);
for(i=1000;i>=0;i--){
if(arr[i]!=0)
printf(" %d %.1lf",i,arr[i]);
}
printf("\n");
}
return 0;
}

修改如下,num值单独计算,然后空间开辟稍大,通过了:

#include<stdio.h>

int main(){
int k,n;
double a;
int i;
while(scanf("%d",&k)!=EOF){

double arr[1004];
int num = 0;
for(i=0;i<1004;i++){
arr[i] = 0;
}
for(i=0;i<k;i++){
scanf("%d %lf",&n,&a);
arr
= arr
+a;
}
scanf("%d",&k);
for(i=0;i<k;i++){
scanf("%d %lf",&n,&a);
arr
= arr
+a;
}
for(i=1000;i>=0;i--){
if(arr[i]!=0)
num++;
}

printf("%d",num);
for(i=1000;i>=0;i--){
if(arr[i]!=0)
printf(" %d %.1lf",i,arr[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: