您的位置:首页 > 其它

hdu 3729 I'm Telling the Truth(二分匹配_ 匈牙利算法)

2015-10-12 14:25 513 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3729

I'm Telling the Truth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1700    Accepted Submission(s): 853


[align=left]Problem Description[/align]
After this year’s college-entrance exam, the teacher did a survey in his class on students’ score. There are n students in the class. The students didn’t want to tell their teacher their exact score; they only told their teacher their
rank in the province (in the form of intervals).

After asking all the students, the teacher found that some students didn’t tell the truth. For example, Student1 said he was between 5004th and 5005th, Student2 said he was between 5005th and 5006th, Student3 said he was between 5004th and 5006th, Student4
said he was between 5004th and 5006th, too. This situation is obviously impossible. So at least one told a lie. Because the teacher thinks most of his students are honest, he wants to know how many students told the truth at most.
 
 

[align=left]Input[/align]
There is an integer in the first line, represents the number of cases (at most 100 cases). In the first line of every case, an integer n (n <= 60) represents the number of students. In the next n lines of every case, there are 2 numbers
in each line, Xi and Yi (1 <= Xi <= Yi <= 100000), means the i-th student’s rank is between Xi and Yi, inclusive.

 
 

[align=left]Output[/align]
Output 2 lines for every case. Output a single number in the first line, which means the number of students who told the truth at most. In the second line, output the students who tell the truth, separated by a space. Please note
that there are no spaces at the head or tail of each line. If there are more than one way, output the list with maximum lexicographic. (In the example above, 1 2 3;1 2 4;1 3 4;2 3 4 are all OK, and 2 3 4 with maximum lexicographic)
 
 

[align=left]Sample Input[/align]

2
4
5004 5005
5005 5006
5004 5006
5004 5006
7
4 5
2 3
1 2
2 2
4 4
2 3
3 4

 
 

[align=left]Sample Output[/align]

3
2 3 4
5
1 3 5 6 7

 
[align=left]Source[/align]
2010 Asia Tianjin Regional Contest

 
 
题目大意:每个人说一个自己成绩排名的区间,但是根据他们所说的会产生矛盾。现在给你一个任务,要你来判断到底谁说的是正确的!输出说真话人的数量以及说真话的人的序号。
解题思路:我们可以把区间的左部分看做是二分图的左枝,区间的右部分看做是二分图的右枝。
特别注意:输出是有要求的,有很多种情况的时候,输出最大的字典序。
 
详见代码。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int n;
int ok[100000+10],vis[100000+10],as[100000+10];
struct node{
int x,y;
}s[110];
int num[100000+10];

bool Find(int x)
{
for (int i=s[x].x;i<=s[x].y;i++)
{
if (!vis[i])
{
vis[i]=1;
if (!ok[i])
{
as[x]=1;
ok[i]=x;
return true;
}
else
{
if (Find(ok[i]))
{
as[x]=1;
ok[i]=x;
return true;
}
}
}
}
return false;
}

int main()
{
int T;
int x,y;

scanf("%d",&T);
while (T--)
{
int k=0;
scanf("%d",&n);
memset(as,0,sizeof(as));
memset(ok,0,sizeof(ok));
int ans=0;
for (int i=1;i<=n;i++)
{
scanf("%d%d",&s[i].x,&s[i].y);
}
for (int i=n;i>0;i--)
{
memset(vis,0,sizeof(vis));
if (Find(i))
ans++;
}
printf ("%d\n",ans);
for (int i=n;i>=1;i--)
{
if (as[i]==1)
{
num[k++]=i;
//cout<<num[k-1]<<endl;
}
}
for (int i=k-1;i>0;i--)
printf ("%d ",num[i]);
printf ("%d\n",num[0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: