您的位置:首页 > 其它

UVA 624 CD (01背包+打印路径 或 dfs+记录路径)

2015-10-11 11:13 477 查看
Description





You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

Assumptions:

number of tracks on the CD. does not exceed 20

no track is longer than N minutes

tracks do not repeat

length of each track is expressed as an integer number

N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input

Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output

Set of tracks (and durations) which are the correct solutions and string `` sum:" and sum of duration times.

Sample Input

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2


Sample Output

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45


题意:给出数m和n,再给出n个数,求从n个数中选出几个和最大的数,并按循序输出这些书和这些数的和。

dfs搜索并记录路径就可以了。也可以用01背包。

dfs:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,n1,sum,ans[22],a[22],str[22];
void dfs(int x,int s,int p)
{
if (s>m) return ;
if (s>sum)
{
sum=s;
for (int i=0;i<p;i++) ans[i]=str[i];
n1=p;
}
for (int i=x+1;i<=n;i++)
{
str[p]=a[i];
dfs(i,s+a[i],p+1);
}
}
int main()
{
int i;
while (~scanf("%d%d",&m,&n))
{
sum=0;
n1=0;
for (i=1;i<=n;i++) scanf("%d",&a[i]);
dfs(0,0,0);
for (i=0;i<n1;i++) printf("%d ",ans[i]);
printf("sum:%d\n",sum);
}
return 0;
}


01:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[10005],v[22][10005];
int main()
{
int n,m,i,j;
int a[22];
while (~scanf("%d%d",&m,&n))
{
memset(dp,0,sizeof(dp));
memset(v,0,sizeof(v));
for (i=1;i<=n;i++) scanf("%d",&a[i]);
for (i=n;i>=1;i--)
{
for (j=m;j>=a[i];j--)
{
if (dp[j]<dp[j-a[i]]+a[i])
{
dp[j]=dp[j-a[i]]+a[i];
v[i][j]=1;
}
}
}
for (i=1,j=dp[m];i<=n;i++)
{
if (v[i][j])
{
printf("%d ",a[i]);
j-=a[i];
}
}
printf("sum:%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: