您的位置:首页 > 其它

hdu--2955

2015-10-10 21:25 239 查看


Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17016 Accepted Submission(s): 6280



Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before
retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line
j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05


Sample Output

2
4
6

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2955
考查知识点:0-1背包
解题思路:Roy在抢劫的时候只有两种状态(逃脱/被抓),每种银行的数量只有一个,满足0-1背包两种特点。考虑被抓的概率可以转换成逃脱的概率,令银行中钱的总合为背包的容量,逃脱的概率为元素价值,求每种背包容量的最大逃脱率。如果逃脱率大于1-P,则输出此时满足条件对应的背包中容量最大的,否则输出0;
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
double p[110];
int mon[110];
double f[10010];
int main()
{
int t,i,j,n,sum;
scanf("%d",&t);
double maxp;
while(t--)
{
scanf("%lf%d",&maxp,&n);
sum=0;
for(i=1;i<=n;i++)
{
scanf("%d%lf",&mon[i],&p[i]);
sum+=mon[i];
}
memset(f,0,sizeof(f));
f[0]=1;//当抢劫的银行为0时,逃离的概率为1
for(i=1;i<=n;i++)
{
for(j=sum;j>=mon[i];j--)
{

f[j]=max(f[j],f[j-mon[i]]*(1-p[i]));
}

}
int flag=1;
for(i=sum;i>=1;i--)
{
if(f[i]>=1-maxp)
{
printf("%d\n",i);
flag=0;
break;
}
}
if(flag)printf("0\n");

}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: