您的位置:首页 > 其它

HDU 5067-Harry And Dig Machine(DFS)

2015-10-10 14:20 351 查看


Harry And Dig Machine

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 435 Accepted Submission(s): 153



Problem Description

As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English,
and even algorithm.

Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there
in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides
to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big
enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?

Input

They are sever test cases, you should process to the end of file.

For each test case, there are two integers n and m.(1≤n,m≤50).

The next n line, each line contains m integer. The j-th number of ith line
a[i][j] means there are a[i][j] stones on the jth cell
of the ith line.( 0≤a[i][j]≤100 ,
and no more than 10 of a[i][j] will be positive integer).

Output

For each test case, just output one line that contains an integer indicate the minimal time that Harry can finish his job.

Sample Input

3 3
0 0 0
0 100 0
0 0 0
2 2
1 1
1 1


Sample Output

4
4BC的b题。一開始写的dfs后来挂掉了。后来才知道自己傻逼了居然妄图想搜全图。

。题解给的是状压DP,蒟蒻还不会。

。由于题意是要让清掉非0的数字且步数最小,我们能够把图中非0的数字的坐标取出来爆搜这些点就能够了,注意用最优性剪一下。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define ll long long
using namespace std;
const int INF=1<<27;
const int maxn=1010;
int ans,num,n,m,a[55][55];
bool vis[12];
int tx[12],ty[12];
void dfs(int x,int y,int goal,int step)
{
//最优性剪枝。这个比較好想
if(step>ans)return ;
if(goal==num)
{
ans=min(ans,step+x-1+y-1);
return ;
}
for(int i=0;i<num;i++)
{
if(!vis[i])
{
vis[i]=1;
int st=step+abs(x-tx[i])+abs(y-ty[i]);
dfs(tx[i],ty[i],goal+1,st);
vis[i]=0;
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
num=0;
memset(vis,0,sizeof(vis));
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
{
scanf("%d",&a[i][j]);
if(i==1&&j==1)continue;
if(a[i][j])
{
tx[num]=i;
ty[num++]=j;
}
}
ans=INF;
dfs(1,1,0,0);
printf("%d\n",ans);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: