您的位置:首页 > 其它

HDOJ1010 Tempter of the Bone(DFS)

2015-10-10 10:46 531 查看
点击打开链接

Tempter of the Bone

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could
feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the
maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0

Sample Output

NO

YES

题解:dfs 搜索题,也是搜素入门的题目,第一个奇偶剪枝一般是用这个去学习的,作为记录。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
using namespace std;

char s[8][8];
int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};//遍历方向
int n,m,k,step,aa,bb,vis[108][108];
bool ans;

void dfs(int x,int y,int deep)
{
if(deep==k&&x==aa&&y==bb){
ans=1;
}
if(ans)
return ;
int temp=k-deep-abs(x-aa)-abs(y-bb);//奇偶剪枝
if(temp&1||temp<0)
return ;
for(int i=0;i<4;i++){
int dx=x+dir[i][0];
int dy=y+dir[i][1];
if(dx<n&&dx>=0&&dy<m&&dy>=0&&s[dx][dy]!='X'&&vis[dx][dy]==0){
vis[dx][dy]=1;
dfs(dx,dy,deep+1);
vis[dx][dy]=0;
}
}
}

int main()
{
while(scanf("%d%d%d",&n,&m,&k)==3&&(n||m||k)){
for(int i=0;i<n;i++)
scanf("%s",s[i]);
int xx,yy;
int sum=0;
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++)
for(int j=0;j<m;j++){
if(s[i][j]=='S'){
xx=i;
yy=j;
}
if(s[i][j]=='D'){
aa=i;
bb=j;
sum++;
}
if(s[i][j]=='.')
sum++;
}
ans=0;
vis[xx][yy]=1;
if(k<=sum)//一个简单的剪枝
dfs(xx,yy,0);
if(ans)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: