您的位置:首页 > 移动开发

hdu 5119__Happy Matt Friends

2015-10-09 19:27 218 查看


Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)

Total Submission(s): 1642    Accepted Submission(s): 646


Problem Description

Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.

 

Input

The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.

 

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.

 

Sample Input

2
3 2
1 2 3
3 3
1 2 3

 

Sample Output

Case #1: 4
Case #2: 2

HintIn the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.

 

Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

 

题意:给出n个数要求任意数量的数的异或和大于m的方案数。

想法:类似于背包问题。对于第i个数,可以选择取或不取,取就是dp[i-1][j^a[i]],不取就是dp[i-1][j];所以状态转移方程是dp[i][j]=dp[i-1][j]+dp[i-1][j^a[i]];

代码如下:

#include<cstdio>
#include<cstring>
int t,n,m,ch[44],dp[44][1<<20];
int main()
{
scanf("%d",&t);
int cas=1;
while(t--) {
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++) {
scanf("%d",&ch[i]);
}
memset(dp,0,sizeof(dp));
dp[0][0]=1;
for(int i=1;i<=n;i++) {
for(int j=0;j<=(1<<20);j++) {
dp[i][j]=dp[i-1][j]+dp[i-1][j^ch[i]];
}
}
long long ans=0;
for(int i=m;i<(1<<20);i++) {
ans+=dp
[i];
}
printf("Case #%d: %lld\n",cas++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm