您的位置:首页 > 其它

BZOJ 1208: [HNOI2004]宠物收养所

2015-10-09 19:01 381 查看

1208: [HNOI2004]宠物收养所

Time Limit: 10 Sec Memory Limit: 162 MB
Submit: 5688 Solved: 2187

Description

最近,阿Q开了一间宠物收养所。收养所提供两种服务:收养被主人遗弃的宠物和让新的主人领养这些宠物。每个领养者都希望领养到自己满意的宠物,阿Q根据领养者的要求通过他自己发明的一个特殊的公式,得出该领养者希望领养的宠物的特点值a(a是一个正整数,a<2^31),而他也给每个处在收养所的宠物一个特点值。这样他就能够很方便的处理整个领养宠物的过程了,宠物收养所总是会有两种情况发生:被遗弃的宠物过多或者是想要收养宠物的人太多,而宠物太少。 1. 被遗弃的宠物过多时,假若到来一个领养者,这个领养者希望领养的宠物的特点值为a,那么它将会领养一只目前未被领养的宠物中特点值最接近a的一只宠物。(任何两只宠物的特点值都不可能是相同的,任何两个领养者的希望领养宠物的特点值也不可能是一样的)如果有两只满足要求的宠物,即存在两只宠物他们的特点值分别为a-b和a+b,那么领养者将会领养特点值为a-b的那只宠物。 2. 收养宠物的人过多,假若到来一只被收养的宠物,那么哪个领养者能够领养它呢?能够领养它的领养者,是那个希望被领养宠物的特点值最接近该宠物特点值的领养者,如果该宠物的特点值为a,存在两个领养者他们希望领养宠物的特点值分别为a-b和a+b,那么特点值为a-b的那个领养者将成功领养该宠物。 一个领养者领养了一个特点值为a的宠物,而它本身希望领养的宠物的特点值为b,那么这个领养者的不满意程度为abs(a-b)。【任务描述】你得到了一年当中,领养者和被收养宠物到来收养所的情况,希望你计算所有收养了宠物的领养者的不满意程度的总和。这一年初始时,收养所里面既没有宠物,也没有领养者。

Input

第一行为一个正整数n,n<=80000,表示一年当中来到收养所的宠物和领养者的总数。接下来的n行,按到来时间的先后顺序描述了一年当中来到收养所的宠物和领养者的情况。每行有两个正整数a, b,其中a=0表示宠物,a=1表示领养者,b表示宠物的特点值或是领养者希望领养宠物的特点值。(同一时间呆在收养所中的,要么全是宠物,要么全是领养者,这些宠物和领养者的个数不会超过10000个)

Output

仅有一个正整数,表示一年当中所有收养了宠物的领养者的不满意程度的总和mod 1000000以后的结果。

Sample Input

5

0 2

0 4

1 3

1 2

1 5

Sample Output

3

(abs(3-2) + abs(2-4)=3,最后一个领养者没有宠物可以领养)

HINT

Source

Splay

解题:Splay

#include <bits/stdc++.h>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 100010;
const int mod = 1000000;
struct SplayTree {
int val[maxn],fa[maxn],ch[maxn][2];
int root,tot;
void init() {
root = tot = fa[0] = 0;
ch[0][0] = ch[0][1] = 0;
}
void newnode(int &x,int key,int f) {
val[x = ++tot] = key;
fa[x] = f;
ch[x][0] = ch[x][1] = 0;
}
void rotate(int x,int kd) {
int y = fa[x];
ch[y][kd^1] = ch[x][kd];
fa[ch[x][kd]] = y;
fa[x] = fa[y];
fa[y] = x;
ch[x][kd] = y;
if(fa[x]) ch[fa[x]][y == ch[fa[x]][1]] = x;
}
void Splay(int x,int goal) {
while(fa[x] != goal) {
if(fa[fa[x]] == goal) rotate(x,x == ch[fa[x]][0]);
else {
int y = fa[x],z = fa[y],s = (ch[z][0] == y);
if(x == ch[y][s]) {
rotate(x,!s);
rotate(x,s);
} else {
rotate(y,s);
rotate(x,s);
}
}
}
if(!goal) root = x;
}
void insert(int key) {
if(!root) {
newnode(root,key,0);
return;
}
int x = root;
while(ch[x][val[x] < key]) x = ch[x][val[x] < key];
newnode(ch[x][val[x] < key],key,x);
Splay(tot,0);
}
int precursor(int key) {
int ret = -INF,x = root;
while(x) {
if(val[x] <= key) {
ret = x;
x = ch[x][1];
} else x = ch[x][0];
}
return ret;
}
int sucessor(int key) {
int x = root,ret = INF;
while(x) {
if(val[x] >= key) {
ret = x;
x = ch[x][0];
} else x = ch[x][1];
}
return ret;
}
void delNode(int x) {
Splay(x,0);
if(ch[x][0] || ch[x][1]) {
if(!ch[x][0]) fa[root = ch[x][1]] = 0;
if(!ch[x][1]) fa[root = ch[x][0]] = 0;
if(ch[x][0] && ch[x][1]) {
int y = ch[x][0];
while(ch[y][1]) y = ch[y][1];
Splay(y,x);
ch[y][1] = ch[x][1];
fa[root = y] = 0;
fa[ch[x][1]] = y;
}
} else root = 0;
}
int Find(int key) {
int x = root;
while(x) {
if(val[x] == key) return x;
x = ch[x][val[x] < key];
}
return 0;
}
} spt;
int main() {
spt.init();
int n,kind,k,tkind = -1,ret = 0;
scanf("%d",&n);
for(int i = 1; i <= n; ++i) {
scanf("%d%d",&kind,&k);
if(!spt.root || kind == tkind) {
tkind = kind;
spt.insert(k);
} else {
int root = spt.Find(k);
if(root) {
spt.delNode(root);
continue;
}
int a = spt.precursor(k),aa;
int b = spt.sucessor(k),bb;
if(a != -INF) aa = spt.val[a];
else aa = INF;
if(b != INF) bb = spt.val[b];
else bb = INF;
if(abs(aa - k) <= abs(bb - k)){
ret = (ret + abs(aa - k))%mod;
spt.delNode(a);
}else{
ret = (ret + abs(bb - k))%mod;
spt.delNode(b);
}
}
}
printf("%d\n",ret);
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: