您的位置:首页 > 其它

HDU 1075 What Are You Talking About (字符串处理)

2015-10-09 11:33 387 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1075

题面:


What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 17717    Accepted Submission(s): 5772


Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help
him?

 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains
two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single
line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new
word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single
string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

Output

In this problem, you have to output the translation of the history book.

 

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

 

Sample Output

hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.

题目大意:

    可以翻译的就翻译,不行的就保持原样。

解题:

    每行句子肯定以符号结尾,故可以直接处理。用map映射下就好。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
using namespace std;
map <string,string> refl;
int main()
{
string s1,s2,tmp,s;
cin>>s1;
while(1)
{
cin>>s1;
if(s1=="END")break;
cin>>s2;
refl[s2]=s1;
}
cin>>s1;
getchar();
while(getline(cin,s))
{
if(s=="END")break;
tmp="";
int len=s.length();
for(int i=0;i<len;i++)
{
if(s[i]>='a'&&s[i]<='z')
{
tmp+=s[i];
}
else
{
if(refl.count(tmp))
{
cout<<refl[tmp];
}
else
{
cout<<tmp;
}
cout<<s[i];
tmp="";
}
}
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  map 入门