您的位置:首页 > 其它

hdoj Card Game 5494 ()简单题

2015-10-08 21:15 281 查看

Card Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 254    Accepted Submission(s): 197


[align=left]Problem Description[/align]
Soda and Beta are good friends. They are going to play a card game today. Soda has
n
cards with number a1,a2,...,an
while Beta has n
cards with number b1,b2,...,bn.

First, they choose a number m
no larger than n.
Then they both randomly select m
cards from their own n
cards. The one with larger sum of the selected cards will win. Soda wants to know if he can always win no mater what cards will be randomly selected from him and Beta.

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integer
T(1≤T≤100),
indicating the number of test cases. For each test case:

The first line contains two integer n
and m
(1≤m≤n≤500).
The second line contains n
integers a1,a2,...,an
(1≤ai≤1000)
denoting Soda's cards. The third line contains n
integers b1,b2,...,bn
(1≤bi≤1000)
denoting Beta's cards.

[align=left]Output[/align]
For each test case, output "YES" (without the quotes) if Soda can always win, otherwise output "NO" (without the quotes) in a single line.

[align=left]Sample Input[/align]

2
3 1
4 5 6
1 2 3
5 2
3 4 7 8 9
3 4 5 2 3

[align=left]Sample Output[/align]

YES
NO 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1010];
int b[1010];
int main()
{
int t,n,m,i,j;
int sum1,sum2;
scanf("%d",&t);
while(t--)
{
sum1=sum2=0;
scanf("%d%d",&n,&m);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=0;i<n;i++)
scanf("%d",&b[i]);
sort(a,a+n);
sort(b,b+n);
for(i=0;i<m;i++)
sum1+=a[i];
for(i=n-1;i>=n-m;i--)
sum2+=b[i];
if(sum1>sum2)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: